Skip to content

Commit

Permalink
Merge branch 'openwrt:master' into patch-1
Browse files Browse the repository at this point in the history
  • Loading branch information
jdbaldry authored Oct 18, 2024
2 parents 171f68f + dd2e710 commit 0166673
Show file tree
Hide file tree
Showing 119 changed files with 1,026 additions and 554 deletions.
3 changes: 3 additions & 0 deletions .vscode/settings.json
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
{
"git.alwaysSignOff": true
}
4 changes: 1 addition & 3 deletions CONTRIBUTING.md
Original file line number Diff line number Diff line change
Expand Up @@ -200,9 +200,7 @@ created packages and runs a script called `test.sh` located next to the package
Makefile. The script is executed with the two arguments `PKG_NAME` and
`PKG_VERSION`. The `PKG_NAME` can be used to distinguish package variants, e.g.
`foobar` vs. `foobar-full`. The `PKG_VERSION` can be used for a trivial test
checking if `foobar --version` prints the correct version. `PKG_VERSION` is the
OpenWrt version and therefore includes the `PKG_RELEASE`, which isn't usually
part of the running programs version.
checking if `foobar --version` prints the correct version.

The following snippet shows a script that tests different binaries depending on
what IPK package was installed. The `gpsd` Makefile produces both a `gpsd` and
Expand Down
4 changes: 2 additions & 2 deletions admin/btop/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=btop
PKG_VERSION:=1.3.2
PKG_VERSION:=1.4.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://codeload.github.com/aristocratos/btop/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=331d18488b1dc7f06cfa12cff909230816a24c57790ba3e8224b117e3f0ae03e
PKG_HASH:=ac0d2371bf69d5136de7e9470c6fb286cbee2e16b4c7a6d2cd48a14796e86650

PKG_MAINTAINER:=Tianling Shen <[email protected]>
PKG_LICENSE:=Apache-2.0
Expand Down
5 changes: 4 additions & 1 deletion admin/fluent-bit/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -41,7 +41,10 @@ CMAKE_OPTIONS+= \
-DFLB_CHUNK_TRACE=No \
-DFLB_BACKTRACE=No \
-DFLB_WASM=No \
-DFLB_LUAJIT=No
-DFLB_LUAJIT=No \
-DWITH_SASL=No \
-DWITH_ZLIB=No \
-DWITH_ZSTD=No

define Package/fluent-bit/install
$(INSTALL_DIR) $(1)/usr/sbin
Expand Down
6 changes: 3 additions & 3 deletions admin/openwisp-config/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,14 +5,14 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=openwisp-config
PKG_VERSION:=1.0.1
PKG_RELEASE:=3
PKG_VERSION:=1.1.0
PKG_RELEASE:=1

PKG_MAINTAINER:=Federico Capoano <[email protected]>
PKG_LICENSE:=GPL-3.0-or-later

PKG_SOURCE_URL:=https://github.com/openwisp/openwisp-config.git
PKG_MIRROR_HASH:=14d65c0aa092b5815bcc3b53c26784a069adf783d3e2c6f5f13a4d62024e5620
PKG_MIRROR_HASH:=c78dc17353c642a6f998531f18e20f0651f946d665506a000308e77c02324a79
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=$(PKG_VERSION)

Expand Down
6 changes: 3 additions & 3 deletions admin/openwisp-monitoring/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,15 +5,15 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=openwisp-monitoring
PKG_VERSION:=0.1.1
PKG_RELEASE:=3
PKG_VERSION:=0.2.0
PKG_RELEASE:=1

PKG_MAINTAINER:=Federico Capoano <[email protected]>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=LICENSE

PKG_SOURCE_URL:=https://github.com/openwisp/openwrt-openwisp-monitoring.git
PKG_MIRROR_HASH:=97ae00b37518919079d894622c664d330bbf0cb0ee1b68c84991b459c1a087ee
PKG_MIRROR_HASH:=6baad2b319cdc072a83547593b447e2c93c42fcdda386f5993c22b88ad991cdd
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
PKGARCH:=all
Expand Down
2 changes: 1 addition & 1 deletion lang/golang/golang-build.sh
Original file line number Diff line number Diff line change
Expand Up @@ -120,7 +120,7 @@ build() {
if [ "$GO_GO_GENERATE" = 1 ]; then
log "Calling go generate"
# shellcheck disable=SC2086
GOOS='' GOARCH='' GO386='' GOARM='' GOMIPS='' GOMIPS64='' \
GOOS='' GOARCH='' GO386='' GOARM='' GOARM64='' GOMIPS='' GOMIPS64='' GORISCV64=''\
go generate -v $targets
log
fi
Expand Down
9 changes: 3 additions & 6 deletions lang/golang/golang-compiler.mk
Original file line number Diff line number Diff line change
Expand Up @@ -19,14 +19,11 @@ define GoCompiler/Default/CheckHost
endef

# $(1) source go root
# $(2) destination prefix
# $(3) go version id
# $(4) additional environment variables (optional)
# $(2) additional environment variables (optional)
define GoCompiler/Default/Make
( \
cd "$(1)/src" ; \
$(if $(2),GOROOT_FINAL="$(2)/lib/go-$(3)") \
$(4) \
$(2) \
$(BASH) make.bash \
$(if $(findstring s,$(OPENWRT_VERBOSE)),-v) \
--no-banner \
Expand Down Expand Up @@ -156,7 +153,7 @@ define GoCompiler/AddProfile

# $$(1) additional environment variables (optional)
define GoCompiler/$(1)/Make
$$(call GoCompiler/Default/Make,$(2),$(3),$(4),$$(1))
$$(call GoCompiler/Default/Make,$(2),$$(1))
endef

# $$(1) override install prefix (optional)
Expand Down
2 changes: 2 additions & 0 deletions lang/golang/golang-values.mk
Original file line number Diff line number Diff line change
Expand Up @@ -59,11 +59,13 @@ unexport \
# Architecture-specific environment variables:
unexport \
GOARM \
GOARM64 \
GO386 \
GOAMD64 \
GOMIPS \
GOMIPS64 \
GOPPC64 \
GORISCV64 \
GOWASM

# Environment variables for use with code coverage:
Expand Down
9 changes: 4 additions & 5 deletions lang/golang/golang/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,8 +7,8 @@

include $(TOPDIR)/rules.mk

GO_VERSION_MAJOR_MINOR:=1.22
GO_VERSION_PATCH:=7
GO_VERSION_MAJOR_MINOR:=1.23
GO_VERSION_PATCH:=2

PKG_NAME:=golang
PKG_VERSION:=$(GO_VERSION_MAJOR_MINOR)$(if $(GO_VERSION_PATCH),.$(GO_VERSION_PATCH))
Expand All @@ -20,7 +20,7 @@ GO_SOURCE_URLS:=https://dl.google.com/go/ \

PKG_SOURCE:=go$(PKG_VERSION).src.tar.gz
PKG_SOURCE_URL:=$(GO_SOURCE_URLS)
PKG_HASH:=66432d87d85e0cfac3edffe637d5930fc4ddf5793313fe11e4a0f333023c879f
PKG_HASH:=36930162a93df417d90bd22c6e14daff4705baac2b02418edda671cdfa9cd07f

PKG_MAINTAINER:=Jeffery To <[email protected]>
PKG_LICENSE:=BSD-3-Clause
Expand All @@ -34,7 +34,6 @@ PKG_BUILD_FLAGS:=no-mips16

PKG_GO_PREFIX:=/usr
PKG_GO_VERSION_ID:=$(GO_VERSION_MAJOR_MINOR)
PKG_GO_ROOT:=$(PKG_GO_PREFIX)/lib/go-$(PKG_GO_VERSION_ID)

HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/go-$(PKG_VERSION)
HOST_BUILD_PARALLEL:=1
Expand Down Expand Up @@ -65,6 +64,7 @@ HOST_GO_VALID_OS_ARCH:= \
wasip1_wasm \
\
freebsd_riscv64 \
openbsd_riscv64 \
\
linux_ppc64 linux_ppc64le \
linux_mips linux_mipsle linux_mips64 linux_mips64le \
Expand Down Expand Up @@ -394,7 +394,6 @@ define Build/Compile
cd "$(PKG_BUILD_DIR)/bin" ; \
export $(GO_PKG_TARGET_VARS) ; \
$(CP) go go-host ; \
GOROOT_FINAL="$(PKG_GO_ROOT)" \
GO_GCC_HELPER_CC="$(TARGET_CC)" \
GO_GCC_HELPER_CXX="$(TARGET_CXX)" \
$(PKG_GO_VARS) \
Expand Down
4 changes: 2 additions & 2 deletions lang/node/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=node
PKG_VERSION:=20.17.0
PKG_VERSION:=20.18.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nodejs.org/dist/v$(PKG_VERSION)
PKG_HASH:=409bda5f1896c7c20866610d778d1760991884ad2e7940837cd3f2854cf73747
PKG_HASH:=c0819f8fc5038584d24c22002aeffd23f2d4a6fd6b337b30c502cbe4a659720c
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-v$(PKG_VERSION)

Expand Down
4 changes: 2 additions & 2 deletions lang/node/patches/201-zlib_gyp.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
--- a/deps/zlib/zlib.gyp
+++ b/deps/zlib/zlib.gyp
@@ -9,6 +9,7 @@
@@ -8,6 +8,7 @@
'use_system_zlib%': 0,
'arm_fpu%': '',
'llvm_version%': '0.0',
},
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
'conditions': [
Expand Down
6 changes: 3 additions & 3 deletions lang/node/patches/204-v8_gyp.patch
Original file line number Diff line number Diff line change
Expand Up @@ -136,9 +136,9 @@
'include_dirs': [
'<(V8_ROOT)/include',
],
@@ -1988,15 +2009,19 @@
'WARNING_CFLAGS!': ['-Wno-invalid-offsetof']
},
@@ -1982,15 +2003,19 @@
}],
],
'direct_dependent_settings': {
+ 'include_dirs!': [ '<!@(echo "$STAGING_DIR"/usr/include)' ],
'include_dirs': [
Expand Down
4 changes: 2 additions & 2 deletions lang/php8/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=php
PKG_VERSION:=8.3.11
PKG_VERSION:=8.3.12
PKG_RELEASE:=1

PKG_MAINTAINER:=Michael Heimpold <[email protected]>
Expand All @@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.php.net/distributions/
PKG_HASH:=b862b098a08ab9bf4b36ed12c7d0d9f65353656b36fb0e3c5344093aceb35802
PKG_HASH:=f774e28633e26fc8c5197f4dae58ec9e3ff87d1b4311cbc61ab05a7ad24bd131

PKG_BUILD_PARALLEL:=1
PKG_BUILD_FLAGS:=no-mips16
Expand Down
2 changes: 1 addition & 1 deletion lang/php8/patches/0025-php-5.4.9-fixheader.patch
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ Make generated php_config.h constant across rebuilds.

--- a/configure.ac
+++ b/configure.ac
@@ -1493,7 +1493,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS)
@@ -1507,7 +1507,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS)
EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"

Expand Down
2 changes: 1 addition & 1 deletion lang/php8/patches/1004-disable-phar-command.patch
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@

--- a/configure.ac
+++ b/configure.ac
@@ -1689,13 +1689,13 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
@@ -1703,13 +1703,13 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"

Expand Down
2 changes: 2 additions & 0 deletions lang/rust/rust-values.mk
Original file line number Diff line number Diff line change
Expand Up @@ -104,3 +104,5 @@ CARGO_PKG_CONFIG_VARS= \
TARGET_CFLAGS="$(TARGET_CFLAGS) $(RUSTC_CFLAGS)"

CARGO_PKG_PROFILE:=$(if $(CONFIG_DEBUG),dev,release)

CARGO_RUSTFLAGS+=-Clink-arg=-fuse-ld=$(TARGET_LINKER)
65 changes: 0 additions & 65 deletions libs/libgudev/Makefile

This file was deleted.

4 changes: 3 additions & 1 deletion libs/libmaxminddb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=libmaxminddb
PKG_VERSION:=1.11.0
PKG_RELEASE=1
PKG_RELEASE=2

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/maxmind/libmaxminddb/releases/download/$(PKG_VERSION)
Expand Down Expand Up @@ -45,6 +45,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmaxminddb.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmaxminddb.pc $(1)/usr/lib/pkgconfig
$(SED) 's,libdir=lib,libdir=$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/libmaxminddb.pc
$(SED) 's,includedir=include,includedir=$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libmaxminddb.pc
endef

define Package/libmaxminddb/install
Expand Down
12 changes: 8 additions & 4 deletions libs/libpng/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libpng
PKG_VERSION:=1.6.43
PKG_RELEASE:=1
PKG_VERSION:=1.6.44
PKG_RELEASE:=2

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/libpng
PKG_HASH:=6a5ca0652392a2d7c9db2ae5b40210843c0bbc081cbd410825ab00cc59f14a6c
PKG_HASH:=60c4da1d5b7f0aa8d158da48e8f8afa9773c1c8baa5d21974df61f1886b8ce8e

PKG_MAINTAINER:=Jo-Philipp Wich <[email protected]>
PKG_LICENSE:=Libpng GPL-2.0-or-later BSD-3-Clause
Expand All @@ -36,8 +36,12 @@ CMAKE_OPTIONS += \
-DPNG_TOOLS=OFF \
-DPNG_TESTS=OFF \
-DPNG_FRAMEWORK=OFF \
-DPNG_HARDWARE_OPTIMIZATIONS=O$(if $(findstring powerpc,$(CONFIG_ARCH))$(findstring mips,$(CONFIG_ARCH)),FF,N) \
-DPNG_HARDWARE_OPTIMIZATIONS=ON \
-DPNG_ARM_NEON=$(if $(or $(findstring aarch64,$(CONFIG_ARCH)),$(findstring neon,$(CONFIG_CPU_TYPE))),on,off) \
-DPNG_LOONGARCH_LSX=off \
-DPNG_MIPS_MMI=off \
-DPNG_MIPS_MSA=off \
-DPNG_POWERPC_VSX=off \
-Dld-version-script=OFF

define Build/InstallDev
Expand Down
4 changes: 2 additions & 2 deletions libs/libpng/patches/200-ccache.patch
Original file line number Diff line number Diff line change
Expand Up @@ -6,9 +6,9 @@
set(CMAKE_C_COMPILER "@CMAKE_C_COMPILER@")
+set(CMAKE_C_COMPILER_ARG1 "@CMAKE_C_COMPILER_ARG1@")
set(CMAKE_C_FLAGS @CMAKE_C_FLAGS@)
set(CMAKE_SYSROOT @CMAKE_SYSROOT@)
set(INCDIR "@CMAKE_CURRENT_BINARY_DIR@")
set(PNG_PREFIX "@PNG_PREFIX@")
@@ -62,7 +63,7 @@ if(INPUTEXT STREQUAL ".c" AND OUTPUTEXT
@@ -67,7 +68,7 @@ if(INPUTEXT STREQUAL ".c" AND OUTPUTEXT
set(PNG_PREFIX_DEF "-DPNG_PREFIX=${PNG_PREFIX}")
endif()

Expand Down
Loading

0 comments on commit 0166673

Please sign in to comment.