Skip to content

Commit

Permalink
cbfstool: add -Wno-error=stringop-overflow
Browse files Browse the repository at this point in the history
Needed to ignore `'memcpy' specified bound between 2147483648 and
4294967295 exceeds maximum object size 2147483647`.

Signed-off-by: Michał Iwanicki <[email protected]>
  • Loading branch information
m-iwanicki committed Dec 10, 2024
1 parent ea6f4d2 commit 2e591bf
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From d3d8ca3274e1b9cfbe64d618ccf7f452aab0634c Mon Sep 17 00:00:00 2001
From: Kas User <[email protected]>
Date: Tue, 10 Dec 2024 18:15:41 +0000
Subject: [PATCH] Makefile: Don't error on stringop-overflow

Signed-off-by: Kas User <[email protected]>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index 5bbb0738..6db1187d 100644
--- a/Makefile
+++ b/Makefile
@@ -125,7 +125,7 @@ endif
# Provide default CC and CFLAGS for firmware builds; if you have any -D flags,
# please add them after this point (e.g., -DVBOOT_DEBUG).
DEBUG_FLAGS := $(if $(filter-out 0,${DEBUG}),-g -Og,-g -Os)
-WERROR := -Werror
+WERROR := -Werror -Wno-error=stringop-overflow
FIRMWARE_FLAGS := -nostdinc -ffreestanding -fno-builtin -fno-stack-protector
COMMON_FLAGS := -pipe ${WERROR} -Wall -Wstrict-prototypes -Wtype-limits \
-Wundef -Wmissing-prototypes -Wno-trigraphs -Wredundant-decls -Wshadow \
5 changes: 5 additions & 0 deletions recipes-bsp/coreboot-utils/cbfstool_%.bbappend
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"

SRC_URI += " \
file://0001-Makefile-Don-t-error-on-stringop-overflow.patch;patchdir=3rdparty/vboot \
"

0 comments on commit 2e591bf

Please sign in to comment.